Incoming email issue
Incident Report for BlueFolder
Resolved
The routing issues with emails from Microsoft email servers have been resolved.
Posted Jun 06, 2023 - 13:56 MDT
Monitoring
Our testing has shown that emails are now flowing but it may take several hours for those that have not been returned as undeliverable to show up. We will continue monitoring.
Posted Jun 01, 2023 - 10:52 MDT
Identified
We have made a change that appears to fix the email routing issues from Microsoft email servers.
Posted Jun 01, 2023 - 10:51 MDT
Investigating
We are aware of an issue that affects incoming email from Microsoft email servers and are working with our email service provider to troubleshoot the problem.
Posted May 30, 2023 - 12:50 MDT
This incident affected: Web App.